Gateway Virtual Academy, LLC. uses Blackboard Collaborate as our Virtual Platform for our live classroom instructions. For your child to have the the best virtual classroom experience, there are a few Technical Requirements that should be provided:

Summary
  • Windows or Mac PC less than 4 years old, with adequate RAM (memory, storage (hard drive) and compatible operating system
  • For quality audio, students are required to have a  digital stereo computer Headset (Skype, Hangouts compatible) with a microphone
  • For quality video must have video card and drivers compatible with current video technologiies
  • High speed broadband internet
  • Students overseas should have both a landline phone and high speed internet
  • Updated, current web browser that meets latest security and compatibility standards
System Requirements

The following minimum hardware and software requirements are necessary in order to access an online class through Gateway Virtual Academy’s current version of Blackboard.

MinimumRecommended
Operating SystemWindows Vista, 7, or 8
Mac OSX 10.6, 10.7, 10.8, or 10.9
Windows 7 or 8
Mac OSX 10.7, 10.8, or 10.9
Processor1 GHz processor2 GHz or faster processor
Memory512 MB of RAM2 GB of RAM or higher
Monitor Resolution1024 x 7681024 x 768 or higher
Free Hard Disk Space5 GB of free disk space20 GB or higher of free space
Internet ConnectionBroadband (high-speed) Internet connection with a consistent minimum speed of 1.5 Mbps.Broadband (high-speed) Internet connection with a speed of 4 Mbps or higher
Internet Browser**Respondus Lockdown Browser and IE8, IE9, Safari 4+, Chrome or FirefoxRespondus Lockdown Browser and Firefox
JavaJava is required to use Blackboard. Visit our Java support page for information about troubleshooting Java.
Macromedia Flash PlayerFlash is required to play videos within the Blackboard system. You can download Flash from the Adobe website.

Students are required to have regular, reliable access to a computer with a stable broadband Internet connection. Any system older than 4 years may not have the processing power to work with our current version of Blackboard and its components.

Browser Requirements

The first step to see if your computer is set up for Blackboard is to check your browser compatibility. We strongly recommend Blackboard students use the latest version of Mozilla Firefox for Windows or Mac because it is the most compatible with our current Blackboard system.

Browser DownloadsPCMac
Respondus Lockdown BrowserDownloadDownload
FirefoxDownloadDownload
Google ChromeDownloadDownload
SafariDownloadDownload
Internet ExplorerDownloadn/a